1.6.3 Installation Issue

Aug 20, 2009 at 2:40 AM

Hi there!  Love this project, but for anyone that runs into issue installing 1.6.3, maybe this might help out...

I downloaded the latest release (1.6.3) which essentially is a .zip file containing setup.exe and SPVisualDev2008pd_v1_6_3.msi.  Upon clicking setup.exe I get an error claiming 'Unable to locate application file 'SPVisualDev2008pd_v1_6_2.msi', which makes sense because that file doesn't exist.  There were no other errors in the log file produced by the setup.exe, and I'm not sure if running the setup.exe file is actually necessary.

I decided to just run the .msi file directly and everything seems to go OK until the very end.  An error dialog appears then instantly disappears before I can get a chance to read it.  The setup continued and I was still able to get an "installation succesful" message at the end. 

However, when I start VS2008, I don't see the SPVisualDev node on the projects tree.  So, I looked in the installation path, (%ProgramFiles%/SPVisualDev), grabbed the templates and installed them manually (you can use this page for help: http://stackoverflow.com/questions/749979/visual-studio-2008-how-to-install-an-item-template).  Don't forget to run "devenv /installvstemplates" after you copy the project templates and item templates into the VS folder.

Everything seems to work fine!

Aug 20, 2009 at 11:33 AM
Edited Aug 20, 2009 at 11:35 AM

Thanks for reporting tihis problem. The package has been updated and the setup.exe issue is now fixed. Please report if you manage to see the second error during install again. I have not managed to reproduce this since no more details could be given.

Make sure you run the install program (msi) as an administrator. The install program installs some regkeys in the local machine hive and some files under the program files folder. It can fail if it doesnt have enough permissions.

Tony

Aug 21, 2009 at 2:19 AM

Thanks, Tony!  I love this tool!!!

Sep 6, 2009 at 11:45 PM

Hi,

I am facing the same issue here and I tried to copy the templates and do devenv /installvstemplates. even then it  is not showing up. Could you help me out

I got this error message when I was trying to install this.

Error Image

Also I am able to install the 1.6.2 version

 

Thanks in advance

Deepak

Sep 7, 2009 at 8:40 AM

Okay,

What OS are you running? 2003 / 2008, 32/64 bit, service packs etc. Try describe as many details as possible about your OS.

Regards

Sep 7, 2009 at 10:36 AM

There is a new release called 1.6.4. Could you try install the newer version and see if the problem is fixed?

Regards

Sep 7, 2009 at 9:43 PM

I am using Windows 2003 Server with SP2. I was trying to install with Visual Studio 2008 Professional. I will try the new 1.6.4 version and update the result.

Thanks for the wonderful work, The best part I liked is importing the content type (wonderful is the import of the content types with field values).

Sep 7, 2009 at 9:57 PM
tore7506 wrote:

There is a new release called 1.6.4. Could you try install the newer version and see if the problem is fixed?

Regards

Wow, 1.6.4 is working perfectly. It installed all the templates. Now, off to complete my site provisioning workflow. Thanks tore7506