Not working on Windows 7 x64 (even though WCF Seems to be up & running)

Nov 10, 2009 at 4:58 PM


I must say i did used the tool a lot in the past months and i kinda'of become addicted! I loved hearing that you have a new version, but unfortunally not working on my developer machine anymore.


Windows 7 x64 OEM, RTM (latest updates), with IIS 7 and WCF extensions activated..etc.
SQL2008 Express Edition x64
SharePoint 2007 x64 with SP2 (slipstreamed & installed on Windows 7)  -working perfectly!
Visual Studio Team System 2008 with SP1
WSP Extensions (latest build at Codeplex).

During install everything seemed to work normally, service is started (installed it as Administrator)! Still, after creating a new project based on "SharePoint Artifacts" template you provided, i keep getting exception related to the "SharePoint farm could not be found. Check the service log on account and make sure it has access to the SharePoint config db" (see bellow)., even though it does seem to work!" - I must mention that i did tried all my accounts (even Administrator, all service pool accounts, SP farm admin, etc. for the Windows Service, with restart..etc), still no luck!

System.ServiceModel.FaultException    at SPVisualDev.Services.MainService.FileExistsIn12Hive(String ProjectRelativePath, Int32 PathKind)
   at SPVisualDev.VSAddin.Connect.AddNewFeature()
   at SPVisualDev.VSAddin.Connect.Exec(String commandName, vsCommandExecOption executeOption, Object& varIn, Object& varOut, Boolean& handled)

Kind regards & thank you again for you tremendous work,
C. Marius

Nov 10, 2009 at 7:52 PM

Thank you for you post,

I don't know if I understood all correctly but you are running SharePoint 2007 on Windows 7 correct?

This is simply something that hasn't been tested yet so unfortunately I'm not able to point you to the right direction on what is going wrong with your setup. The error message usualy comes up when the SPVisualDev Windows service is unable to connect to the DB. It could also be issues with the SharePoint API can't read the registry correctly to connect to the config db (this happens when the service is called for the first time). Are you able to do anything through the service? What happens when you stop the service and retry to do the same procedures? If the addin doesn't use the service, which is the case on local 32bit installations then the problem might be other than the service account not having access or wrong account. What installation type did you choose when SPVisualDev was installed? Client or Server.

Hope this might help to pin point your problem.